Posts by fresH229

    Hi,


    canPurchaseInputs="false" ist gesetzt, es zeigt aber nach wie vor an, dass man die Inputsauch kaufen kann.

    Erst wenn ich bei den Inputs den Preis lösche, kann man nichts mehr kaufen.


    Code
    1. <purchase fixedPricePerLitre="1.9" />


    Ist das so gewollt?


    LG.

    Hey,


    vielleicht sieht jemand, was ich nicht sehe.

    Log wirft keine Fehler aus, der Mod wird auch normal geladen. GUI usw. alles da, ich kann nur zum Verrecken keine Rohstoffe direkt kaufen.


    Habe auch das gesetzt, macht keinen Unterschied

    Code
    1. canPurchaseInputs="true"

    LG.

    Files

    Mit dem nächsten Update können neuen Filltypes registriert werden.

    Bin mir nicht sicher in wie weit das möglich ist aber wird ihm nächsten Update eine Möglichkeit geben auch Stückzahl anzugeben anstatt Liter bzw. vielleicht kann man irgendwo was einbauen mit x liter = 1 Stück damit das Script das bei der Anzeige zumindest berrechnen kann?

    lt. Sägewerk.xml vom Tutorial, musst du denk ich auch woodChips beim input angeben, da du ja sonst die SetzlingPaletten in den Schrädder hauen musst damit da was rauskommt (außer das ist der Plan o.O)

    Heyho,


    hier direkt die nächste Frage auf die ich noch keine Antwort gefunden habe.

    Kann man ein AnimatedObject so verbauen, dass es nur aktiv ist, wenn die Maschine läuft.


    Beispiel:

    Ich habe einen Ballenschredder, der aber nur animiert ist wenn die Maschine läuft.

    Den Ballenschieber aktiviere ich mit einem Knopf über die animatedObjects. Die sind aber unabhänging von Zustand der Maschine immer aktiv.


    Jetzt stellt sich die Frage, ob man auch animatedObjects so verbauen kann, das sie nur aktiv sind, wenn die Maschine läuft.


    Dankeee :)

    <3:thumbup:

    HEy joker,


    danke für deine Antwort.

    Habe das nun genau so auch nochmal getestet, aber es bringt den selben Error:


    Ich vermute jetzt einfach mal, das man diese sounds auf Placeables nicht rauflegen kann sondern nur auf <vehicle> :-S


    Wäre die Frage ob man im GC selbst wenn das nicht viel aufwand ist für start/stop/work was einbauen kann, das man das direkt mit der Fabrik definiert.


    LG.

    Kleiner Nachtrag:


    Code
    1. <operateSounds>
    2. <start template="STRAWBLOWER_ANDERSON_START" linkNode="audio" />
    3. <stop template="STRAWBLOWER_ANDERSON_STOP" linkNode="audio" />
    4. <run template="STRAWBLOWER_ANDERSON_WORK" linkNode="audio" />
    5. </operateSounds>


    Damit bekomme ich den Sound vom Strawblower bei der Maschine rein.

    Wie könnte ihc jetzt der Maschine sagen, nimm andere soundfiles für die 3 Sachen?


    Wenn ich das mit externalSoundFile definiere, lacht mich die Maschine aus und nimmt trotzdem die standard sounds :D

    Wobei mir gerade aufgefallen ist, dass wenn ich den Namen ändere, das ganze nicht mehr geht :P;(:D


    Code
    1. 2019-08-08 22:01 Warning: Filename not defined in 'placeable.productionFactories.productionFactory(0).productLines.productLine(0).operatingParts.operateSounds.start'. Ignoring it!
    2. 2019-08-08 22:01 Warning: Filename not defined in 'placeable.productionFactories.productionFactory(0).productLines.productLine(0).operatingParts.operateSounds.run'. Ignoring it!
    3. 2019-08-08 22:01 Warning: Filename not defined in 'placeable.productionFactories.productionFactory(0).productLines.productLine(0).operatingParts.operateSounds.stop'. Ignoring it!


    Okay ich komme nicht dahinter, egal was ich versuche, nix geht :(


    Das steht in meiner xml vom Objekt: (hab es mal mit den Standard Sachen probiert, aber nichtmal die gehen)

    Code
    1. <sounds externalSoundFile="sounds/engine_01.xml"/>
    2. <operateSounds>
    3. <start template="SMALL_TRACTOR_MOTOR_START" linkNode="audio" />
    4. <stop template="SMALL_TRACTOR_MOTOR_STOP" linkNode="audio" />
    5. <run template="SMALL_TRACTOR_MOTOR_IDLE" linkNode="audio" />
    6. </operateSounds>


    Die engine_01.xml:


    Ich habe es auhc mit dem probiert bei allen Einträgen, ging auch nich :(

    XML
    1. <?xml version="1.0" encoding="utf-8" standalone="no" ?>
    2. <soundTemplates>
    3. <template name="xxxx

    Heyho,


    kann man hier auch eigene Soundfiles definieren?

    Code
    1. <operateSounds>
    2. <start template="SILAGE_MIX_START_01" linkNode="audio3" />
    3. <stop template="SILAGE_MIX_STOP_01" linkNode="audio3" />
    4. <run template="SILAGE_MIX_LOOP_01" linkNode="audio3" />
    5. </operateSounds>

    audio3 ist im Grimme nur eine transformgroup, da is nix definiert :-S


    LG.

    Blöde Frage, gibts auf der PortaWestfalica Compost wobei, wenn das der Fehler wäre würde das doch irgendwo stehen :/ Kanns daran liegen?


    Versuch mal als Output Silage zu machen und schau ob das produziert wird.

    San Andreas hier stehts :)