Keine zwei Exhausteffects möglich ?

  • Moin, wollte mir zwei mal die Auspuff Particle einbauen. Die Standards vom Ls funktionieren... Die neuen allerdings nicht. Keine Ahnung woran es liegt..

    Weiß das vielleicht jemand was ?

    Der erste Funktioniert. Der zweite nicht.

    Code
    1. <newExhaustEffects maxMotorLoad="0.8">
    2. <particle node="0>8|12|0" position="0 0 0" rotation="35 0 0" file="scripts/newRealParticles.i3d" />
    3. <particle node="0>8|42" position="0 0 0" rotation="35 0 0" file="scripts/newRealParticles.i3d" />
    4. </newExhaustEffects>

    Dateien

    • log.txt

      (13,65 kB, 2 Mal heruntergeladen, zuletzt: )

    Landwirtschaft aus Leidenschaft ;)

    Gelb und Eckig muss er sein!

    k700ajze6x.png

    kirovetscoic9.png


  • Es sind real exhaust Partikel.

    Zitat


    dann darfst du die nicht kopieren, sonder immer importieren( ggf zuerst exportieren)

    Wie genau meinst du das ?

    Den effekt an sich importiert man ja nicht in das Hauptmodell soweit ich weiß.

    Wie gesagt der zuerst angegebene funktioniert einwandfrei. Der zweite dann nicht mehr.

    Landwirtschaft aus Leidenschaft ;)

    Gelb und Eckig muss er sein!

    k700ajze6x.png

    kirovetscoic9.png


  • Moin T3chn1k , die particel node sollte nicht gleich benannt sein! Hier mal ein Auszug aus Alfredix Schwerlast-TGS :

    Code
    1. <!-- spezi newExhaustEffects 2 exhausts -->
    2. <newExhaustEffects maxMotorLoad="0.1">
    3. <particle node="0>0|0|1|0|1|0" position="0 0 0" rotation="35 0 0" file="particleAnimations/exhaust.i3d" />
    4. <particle2 node="0>0|0|1|0|1|1" position="0 0 0" rotation="35 0 0" file="particleAnimations/exhaust.i3d" />
    5. </newExhaustEffects>

    Hoffe es hilft!


    Gruß Meerstonk

  • ja das steuert mann Dan über eine lua.


    particleAnimations;


    newExhaustEffects.lua


    PumaEffects.lua


    <exhaustEffects>

    <exhaustEffect index="0>24" filename="$data/particleSystems/shared/exhaust.i3d" minRpmColor="0.9 0.9 0.9 0.1" maxRpmColor="0.9 0.9 0.9 0.4" minRpmScale="0.05" maxRpmScale="0.4" xzRotationsOffset="0 0" xzRotationsForward="-250 0" xzRotationsBackward="50 0" xzRotationsLeft="0 100" xzRotationsRight="0 -100" />

    </exhaustEffects>


    <newExhaustEffects maxMotorLoad="0.1">

    <particle node="0>24" position="0 0 0" rotation="35 0 0" file="particleAnimations/newExhaust.i3d" />

    </newExhaustEffects>


    <StartParticleSystem node="0>24" file="particleAnimations/exhaust.i3d" startOffset="1"/>