HoT Animated Object Extend 1.0.3

Aussteigen zum Tore öffnen war früher

HoT Tools



presentiert

HoT AnimatedObject Extend

Ideen muss man haben ;) und einen Scripter (dank geht ganz klar an [HoT]derElky


Aussteigen zum Tore öffnen war gestern




Das kennt ihr ja schon


aber so ists ab heute






Dies ist nur das Script, einfach mit in den Modsordner packen und bei animated Objects folgenden Eintrag beim jeweiligen Tor machen:


<autoOpen use="true" />


Viel Spass mit diesem Script


wünscht das


HoT online Team


  • Version 1.0.3

    HoT_AnimatedObjectExtend/script/AnimatedObjectExtend.lua:72: attempt to call method 'getActiveFarm' (a nil value) - Fehler gefixt

  • Version 1.0.1

    Probleme am Dedi gefixt.

    Änderung am Script - Nur noch für Fahrzeuge - zu Fuss muss das Tor wieder per Hand geöffnet werden

  • Version 1.0.0

  • Moin Mal eine frage. Kann man die Lua im Schlepper einbinden und die einträge für die tore in die animatedObjects XML schreiben.

    Wird es denn Fuktionieren. ??? Ansonsten an welcher stelle von der Tor XML muss der Eintrag stehn.


    Gruß

    • also das script ist global und muss nur in den Modsordner.


      Im Support-Thema steht doch wie es geht

  • Kann ich das auch inplazierbare mods einbaien ?

    • Klar kannst du das auch in platzierbare Mods einbauen

  • Funktioniert wunderbar (echt cool)

  • This version is not good, it does not work.

    The previous one worked fine for 1.0.2.

    There is nothing to rewrite here to "true" as it already has the value ...

    Therefore, I do not understand this version and it is not surprising that it does not work.

    • could you be more detailed what is not working? i tried it and works as aspected.

  • funktioniert das script nur wenn man selber drin sitzt oder auch mit cp / autodrivefahrern?

    • Da ich keins von beiden Nutze kann ich es ehrlich nicht sagen. Aber kannst es gerne versuchen und Rückmeldung geben.

    • Mit AD geht es automatisch auf und zu.


      MFG Mannie313

  • Habe das alte Script mit dem neuen getauscht und bekomme diesen Fehler:


    • Hi,


      im SP?

      Mit welchen Fahrzeug?

      Platziertes Tor oder in der Map verbaut?

      ganze Log?

    • Ich Spiele SP und der Fehler ist sofort da, also sobald ich das Spiel starte und ob Platziertes Tor oder in der Map fest verbaut kann ich nicht sagen da ich beides auf der Map habe. Hier ist die Log ohne Mods im Ordner!


    • Also da sind noch einige Mods bei. Aber ich versuche das mal nachzustellen.

      Kann es sein das der Hund oder der Zug vielleicht in einem Trigger sind? das würde mir jetzt auf die schnelle einfallen da ich dies nicht getestet habe

      Like 1
    • Kann ich nicht sagen, werde es mal testen!


      Edit:

      Habe den Fehler gefunden, ich hatte in meiner Schweinzucht noch zwei zusätzliche Tore verbaut.

      Die funktionierten auch, habe sie aus der Schweinzucht ausgebaut und sie jetzt fest auf der Map verbaut.

      Keine Ahnung was ich da jetzt anders gemacht habe aber es funktioniert und zeigt kein Fehler mehr an.

      Da ich neugierig war ob ich was falsch gemacht hatte, habe ich sie wieder zum Test in die Schweinezucht eingebaut.

      Und siehe da der Fehler war wieder da, keine Ahnung warum!!


      Danke dir dennoch für deine Hilfe DANKE!

    • Ok aber waren die Tore per items.xml geladen? und jetzt fest verbaut funktioniert? Denn es könnten ja noch andere auf diesen Fehler stoßen und vielleicht lässt sich da am Script etwas abfangen.

      Like 1
  • Hi, the correct syntax should be listed as <autoOpen use="true" /> You were missing the closing slash. However, I tested this with a couple of gates and am getting script warnings in the log.


    Warning (script): 'setCollisionMask': Argument 1 has wrong type. Expected: Int. Actual: Nil

    • Pls use the supportthread for your Problems, thanks